MozillaFirefox/MozillaFirefox.spec
branchfirefox97
changeset 1171 130d464159be
parent 1170 f9b2d408b7ef
child 1172 7bdeb580be51
equal deleted inserted replaced
1170:f9b2d408b7ef 1171:130d464159be
     1 #
     1 #
     2 # spec file
     2 # spec file
     3 #
     3 #
     4 # Copyright (c) 2022 SUSE LLC
     4 # Copyright (c) 2022 SUSE LLC
     5 #               2006-2021 Wolfgang Rosenauer <wr@rosenauer.org>
     5 #               2006-2022 Wolfgang Rosenauer <wr@rosenauer.org>
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %major.99
    30 # mainver %major.99
    31 %define major          96
    31 %define major          97
    32 %define mainver        %major.0.3
    32 %define mainver        %major.0.1
    33 %define orig_version   96.0.3
    33 %define orig_version   97.0.1
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
    95 BuildRequires:  gcc9-c++
    95 BuildRequires:  gcc9-c++
    96 %else
    96 %else
    97 BuildRequires:  gcc-c++
    97 BuildRequires:  gcc-c++
    98 %endif
    98 %endif
    99 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
    99 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
   100 BuildRequires:  cargo >= 1.53
   100 BuildRequires:  cargo >= 1.57
   101 BuildRequires:  rust >= 1.53
   101 BuildRequires:  rust >= 1.57
   102 %else
   102 %else
   103 # Newer sle/leap/tw use parallel versioned rust releases which have
   103 # Newer sle/leap/tw use parallel versioned rust releases which have
   104 # a different method for provides that we can use to request a
   104 # a different method for provides that we can use to request a
   105 # specific version
   105 # specific version
   106 BuildRequires:  rust+cargo >= 1.53
   106 BuildRequires:  rust+cargo >= 1.57
   107 %endif
   107 %endif
   108 %if 0%{useccache} != 0
   108 %if 0%{useccache} != 0
   109 BuildRequires:  ccache
   109 BuildRequires:  ccache
   110 %endif
   110 %endif
   111 BuildRequires:  libXcomposite-devel
   111 BuildRequires:  libXcomposite-devel
   112 BuildRequires:  libcurl-devel
   112 BuildRequires:  libcurl-devel
   113 BuildRequires:  libiw-devel
   113 BuildRequires:  libiw-devel
   114 BuildRequires:  libproxy-devel
   114 BuildRequires:  libproxy-devel
   115 BuildRequires:  makeinfo
   115 BuildRequires:  makeinfo
   116 BuildRequires:  mozilla-nspr-devel >= 4.33
   116 BuildRequires:  mozilla-nspr-devel >= 4.33
   117 BuildRequires:  mozilla-nss-devel >= 3.73.1
   117 BuildRequires:  mozilla-nss-devel >= 3.74
   118 BuildRequires:  nasm >= 2.14
   118 BuildRequires:  nasm >= 2.14
   119 BuildRequires:  nodejs >= 10.22.1
   119 BuildRequires:  nodejs >= 10.22.1
   120 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   120 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   121 BuildRequires:  python-libxml2
   121 BuildRequires:  python-libxml2
   122 BuildRequires:  python36
   122 BuildRequires:  python36
   379 %endif
   379 %endif
   380 %endif
   380 %endif
   381 %ifarch %arm %ix86
   381 %ifarch %arm %ix86
   382 # Limit RAM usage during link
   382 # Limit RAM usage during link
   383 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
   383 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
       
   384 # A lie to prevent -Wl,--gc-sections being set which requires more memory than 32bit can offer
       
   385 export GC_SECTIONS_BREAKS_DEBUG_RANGES=yes
   384 %endif
   386 %endif
   385 export LDFLAGS="${LDFLAGS} -fPIC -Wl,-z,relro,-z,now"
   387 export LDFLAGS="${LDFLAGS} -fPIC -Wl,-z,relro,-z,now"
   386 %ifarch ppc64 ppc64le
   388 %ifarch ppc64 ppc64le
   387 %if 0%{?clang_build} == 0
   389 %if 0%{?clang_build} == 0
   388 export CFLAGS="$CFLAGS -mminimal-toc"
   390 export CFLAGS="$CFLAGS -mminimal-toc"
   406 echo "export BUILD_OFFICIAL=1"
   408 echo "export BUILD_OFFICIAL=1"
   407 echo "export MOZ_TELEMETRY_REPORTING=1"
   409 echo "export MOZ_TELEMETRY_REPORTING=1"
   408 echo ""
   410 echo ""
   409 cat << EOF
   411 cat << EOF
   410 %else
   412 %else
   411 %ifarch aarch64 ppc64 ppc64le x86_64
   413 %limit_build -m 2560
   412 %limit_build -m 2048
       
   413 %endif
       
   414 cat << EOF > $MOZCONFIG
   414 cat << EOF > $MOZCONFIG
   415 %endif
   415 %endif
   416 mk_add_options MOZILLA_OFFICIAL=1
   416 mk_add_options MOZILLA_OFFICIAL=1
   417 mk_add_options BUILD_OFFICIAL=1
   417 mk_add_options BUILD_OFFICIAL=1
   418 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   418 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   431 # bmo#1441155 - Disable the generation of Rust debug symbols on Linux32
   431 # bmo#1441155 - Disable the generation of Rust debug symbols on Linux32
   432 %ifarch %ix86 %arm
   432 %ifarch %ix86 %arm
   433 ac_add_options --disable-debug-symbols
   433 ac_add_options --disable-debug-symbols
   434 %else
   434 %else
   435 ac_add_options --enable-debug-symbols=-g1
   435 ac_add_options --enable-debug-symbols=-g1
       
   436 %endif
   436 ac_add_options --disable-install-strip
   437 ac_add_options --disable-install-strip
   437 %endif
       
   438 # building with elf-hack started to fail everywhere with FF73
   438 # building with elf-hack started to fail everywhere with FF73
   439 #%if 0%{?suse_version} > 1549
   439 #%if 0%{?suse_version} > 1549
   440 %ifnarch aarch64 ppc64 ppc64le s390x
   440 %ifnarch aarch64 ppc64 ppc64le s390x
   441 ac_add_options --disable-elf-hack
   441 ac_add_options --disable-elf-hack
   442 %endif
   442 %endif