mozilla-xulrunner20/mozilla-xulrunner20.spec
changeset 232 156406e2b62d
parent 230 e4846f1b81c5
child 236 a4f5954df3a3
equal deleted inserted replaced
231:bb385ce8c773 232:156406e2b62d
   224 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   224 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   225 if test "$kdehelperversion" != %{kde_helper_version}; then
   225 if test "$kdehelperversion" != %{kde_helper_version}; then
   226   echo fix kde helper version in the .spec file
   226   echo fix kde helper version in the .spec file
   227   exit 1
   227   exit 1
   228 fi
   228 fi
       
   229 source other-licenses/branding/firefox/configure.sh
       
   230 unset MOZ_APP_DISPLAYNAME
       
   231 export MOZ_UA_BUILDID
   229 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   232 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   230 export MOZ_BUILD_DATE=%{releasedate}
   233 export MOZ_BUILD_DATE=%{releasedate}
   231 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   234 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   232 %ifarch ppc64
   235 %ifarch ppc64
   233 export CFLAGS="$CFLAGS -mminimal-toc"
   236 export CFLAGS="$CFLAGS -mminimal-toc"