MozillaFirefox/MozillaFirefox.spec
branchfirefox61
changeset 1065 33c6119b5cc5
parent 1063 a0c915e59e05
child 1066 3f18b0f2a868
equal deleted inserted replaced
1063:a0c915e59e05 1065:33c6119b5cc5
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          61
    21 %define major          61
    22 %define mainver        %major.0
    22 %define mainver        %major.0.2
    23 %define orig_version   61.0
    23 %define orig_version   61.0.2
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20180621125625
    27 %define releasedate    20180807170231
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # PIE, full relro (x86_64 for now)
    30 # PIE, full relro (x86_64 for now)
    31 %define build_hardened 1
    31 %define build_hardened 1
    32 
    32 
    61 BuildRequires:  dbus-1-glib-devel
    61 BuildRequires:  dbus-1-glib-devel
    62 BuildRequires:  fdupes
    62 BuildRequires:  fdupes
    63 BuildRequires:  memory-constraints
    63 BuildRequires:  memory-constraints
    64 %if 0%{?suse_version} <= 1320
    64 %if 0%{?suse_version} <= 1320
    65 BuildRequires:  gcc7-c++
    65 BuildRequires:  gcc7-c++
    66 BuildRequires:  python3
       
    67 %else
    66 %else
    68 BuildRequires:  gcc-c++
    67 BuildRequires:  gcc-c++
    69 %endif
    68 %endif
    70 BuildRequires:  cargo
    69 BuildRequires:  cargo
    71 BuildRequires:  libXcomposite-devel
    70 BuildRequires:  libXcomposite-devel
    77 BuildRequires:  makeinfo
    76 BuildRequires:  makeinfo
    78 BuildRequires:  mozilla-nspr-devel >= 4.19
    77 BuildRequires:  mozilla-nspr-devel >= 4.19
    79 BuildRequires:  mozilla-nss-devel >= 3.37.3
    78 BuildRequires:  mozilla-nss-devel >= 3.37.3
    80 BuildRequires:  python-devel
    79 BuildRequires:  python-devel
    81 BuildRequires:  python2-xml
    80 BuildRequires:  python2-xml
       
    81 BuildRequires:  python3 >= 3.5
    82 BuildRequires:  rust >= 1.24
    82 BuildRequires:  rust >= 1.24
    83 BuildRequires:  rust-std
    83 BuildRequires:  rust-std
    84 BuildRequires:  startup-notification-devel
    84 BuildRequires:  startup-notification-devel
    85 BuildRequires:  unzip
    85 BuildRequires:  unzip
    86 BuildRequires:  update-desktop-files
    86 BuildRequires:  update-desktop-files
   157 Patch4:         mozilla-openaes-decl.patch
   157 Patch4:         mozilla-openaes-decl.patch
   158 Patch5:         mozilla-no-stdcxx-check.patch
   158 Patch5:         mozilla-no-stdcxx-check.patch
   159 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   159 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   160 Patch7:         mozilla-aarch64-startup-crash.patch
   160 Patch7:         mozilla-aarch64-startup-crash.patch
   161 Patch8:         mozilla-bmo256180.patch
   161 Patch8:         mozilla-bmo256180.patch
   162 Patch9:         mozilla-enable-csd.patch
   162 Patch9:         mozilla-no-return.patch
   163 Patch10:        mozilla-no-return.patch
   163 Patch10:        mozilla-bmo1464766.patch
   164 Patch11:        mozilla-bmo1464766.patch
       
   165 # Firefox/browser
   164 # Firefox/browser
   166 Patch101:       firefox-kde.patch
   165 Patch101:       firefox-kde.patch
   167 Patch102:       firefox-branded-icons.patch
   166 Patch102:       firefox-branded-icons.patch
   168 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   167 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   169 Requires(post):   coreutils shared-mime-info desktop-file-utils
   168 Requires(post):   coreutils shared-mime-info desktop-file-utils
   269 %ifarch %ix86
   268 %ifarch %ix86
   270 %patch6 -p1
   269 %patch6 -p1
   271 %endif
   270 %endif
   272 %patch7 -p1
   271 %patch7 -p1
   273 %patch8 -p1
   272 %patch8 -p1
   274 #%patch9 -p1
   273 %patch9 -p1
   275 %patch10 -p1
   274 %patch10 -p1
   276 #%patch11 -p1
       
   277 # Firefox
   275 # Firefox
   278 %patch101 -p1
   276 %patch101 -p1
   279 %patch102 -p1
   277 %patch102 -p1
   280 
   278 
   281 %build
   279 %build