MozillaFirefox/MozillaFirefox.spec
branchfirefox17
changeset 574 3f9d8370653d
parent 564 9852e10fdf9b
child 577 96e70217f18a
equal deleted inserted replaced
564:9852e10fdf9b 574:3f9d8370653d
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 %define major 16
    20 %define major 17
    21 %define mainver %major.99
    21 %define mainver %major.0
    22 %define update_channel beta
    22 %define update_channel release
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  Mesa-devel
    25 BuildRequires:  Mesa-devel
    26 BuildRequires:  autoconf213
    26 BuildRequires:  autoconf213
    27 BuildRequires:  dbus-1-glib-devel
    27 BuildRequires:  dbus-1-glib-devel
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    54 %endif
    54 %endif
    55 Version:        %{mainver}
    55 Version:        %{mainver}
    56 Release:        0
    56 Release:        0
    57 %define         releasedate 2012102300
    57 %define         releasedate 2012111600
    58 Provides:       firefox = %{mainver}
    58 Provides:       firefox = %{mainver}
    59 Provides:       firefox = %{version}-%{release}
    59 Provides:       firefox = %{version}-%{release}
    60 Provides:       web_browser
    60 Provides:       web_browser
    61 Provides:       browser(npapi)
    61 Provides:       browser(npapi)
    62 # this is needed to match this package with the kde4 helper package without the main package
    62 # this is needed to match this package with the kde4 helper package without the main package
   274 ac_add_options --prefix=%{_prefix}
   274 ac_add_options --prefix=%{_prefix}
   275 ac_add_options --libdir=%{_libdir}
   275 ac_add_options --libdir=%{_libdir}
   276 ac_add_options --sysconfdir=%{_sysconfdir}
   276 ac_add_options --sysconfdir=%{_sysconfdir}
   277 ac_add_options --mandir=%{_mandir}
   277 ac_add_options --mandir=%{_mandir}
   278 ac_add_options --includedir=%{_includedir}
   278 ac_add_options --includedir=%{_includedir}
   279 #ac_add_options --with-system-nspr
   279 ac_add_options --with-system-nspr
   280 ac_add_options --with-system-nss
   280 ac_add_options --with-system-nss
   281 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   281 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   282 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   282 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   283 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   283 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   284 ac_add_options --with-system-zlib
   284 ac_add_options --with-system-zlib
   287 ac_add_options --disable-tests
   287 ac_add_options --disable-tests
   288 ac_add_options --disable-debug
   288 ac_add_options --disable-debug
   289 ac_add_options --enable-startup-notification
   289 ac_add_options --enable-startup-notification
   290 #ac_add_options --enable-chrome-format=jar
   290 #ac_add_options --enable-chrome-format=jar
   291 ac_add_options --enable-update-channel=%{update_channel}
   291 ac_add_options --enable-update-channel=%{update_channel}
       
   292 ac_add_options --disable-webrtc   # webrtc build is broken for system NSPR
   292 EOF
   293 EOF
   293 %if %suse_version > 1130
   294 %if %suse_version > 1130
   294 cat << EOF >> $MOZCONFIG
   295 cat << EOF >> $MOZCONFIG
   295 ac_add_options --disable-gnomevfs
   296 ac_add_options --disable-gnomevfs
   296 ac_add_options --enable-gio
   297 ac_add_options --enable-gio