MozillaFirefox/MozillaFirefox.spec
branchfirefox74
changeset 1123 7fa561e5d7c7
parent 1122 a9cd24eaa361
child 1124 f890ebd6b627
equal deleted inserted replaced
1122:a9cd24eaa361 1123:7fa561e5d7c7
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          73
    21 %define major          74
    22 %define mainver        %major.0.1
    22 %define mainver        %major.0
    23 %define orig_version   73.0.1
    23 %define orig_version   74.0
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 
    28 
    81 BuildRequires:  libidl-devel
    81 BuildRequires:  libidl-devel
    82 BuildRequires:  libiw-devel
    82 BuildRequires:  libiw-devel
    83 BuildRequires:  libnotify-devel
    83 BuildRequires:  libnotify-devel
    84 BuildRequires:  libproxy-devel
    84 BuildRequires:  libproxy-devel
    85 BuildRequires:  makeinfo
    85 BuildRequires:  makeinfo
    86 BuildRequires:  mozilla-nspr-devel >= 4.24
    86 BuildRequires:  mozilla-nspr-devel >= 4.25
    87 BuildRequires:  mozilla-nss-devel >= 3.49.2
    87 BuildRequires:  mozilla-nss-devel >= 3.50
    88 BuildRequires:  nasm >= 2.13
    88 BuildRequires:  nasm >= 2.13
    89 BuildRequires:  nodejs8 >= 8.11
    89 BuildRequires:  nodejs8 >= 8.11
    90 BuildRequires:  python-devel
    90 BuildRequires:  python-devel
    91 BuildRequires:  python2-xml
    91 BuildRequires:  python2-xml
    92 BuildRequires:  python3 >= 3.5
    92 BuildRequires:  python3 >= 3.5
    93 BuildRequires:  rust >= 1.39
    93 BuildRequires:  rust >= 1.39
    94 BuildRequires:  rust-cbindgen >= 0.12.0
    94 BuildRequires:  rust-cbindgen >= 0.13.0
    95 BuildRequires:  startup-notification-devel
    95 BuildRequires:  startup-notification-devel
    96 BuildRequires:  unzip
    96 BuildRequires:  unzip
    97 BuildRequires:  update-desktop-files
    97 BuildRequires:  update-desktop-files
    98 BuildRequires:  xorg-x11-libXt-devel
    98 BuildRequires:  xorg-x11-libXt-devel
    99 %if 0%{?do_profiling}
    99 %if 0%{?do_profiling}
   167 Patch1:         mozilla-nongnome-proxies.patch
   167 Patch1:         mozilla-nongnome-proxies.patch
   168 Patch2:         mozilla-kde.patch
   168 Patch2:         mozilla-kde.patch
   169 Patch3:         mozilla-ntlm-full-path.patch
   169 Patch3:         mozilla-ntlm-full-path.patch
   170 Patch4:         mozilla-aarch64-startup-crash.patch
   170 Patch4:         mozilla-aarch64-startup-crash.patch
   171 Patch5:         mozilla-bmo1463035.patch
   171 Patch5:         mozilla-bmo1463035.patch
   172 Patch6:         mozilla-cubeb-noreturn.patch
   172 Patch6:         mozilla-sandbox-fips.patch
   173 Patch7:         mozilla-fix-aarch64-libopus.patch
   173 Patch7:         mozilla-fix-aarch64-libopus.patch
   174 Patch8:         mozilla-disable-wasm-emulate-arm-unaligned-fp-access.patch
   174 Patch8:         mozilla-disable-wasm-emulate-arm-unaligned-fp-access.patch
   175 Patch9:         mozilla-s390-context.patch
   175 Patch9:         mozilla-s390-context.patch
   176 Patch10:        mozilla-s390-bigendian.patch
   176 Patch10:        mozilla-s390-bigendian.patch
   177 Patch11:        mozilla-reduce-rust-debuginfo.patch
   177 Patch11:        mozilla-reduce-rust-debuginfo.patch
   184 Patch18:        mozilla-bmo1554971.patch
   184 Patch18:        mozilla-bmo1554971.patch
   185 Patch19:        mozilla-bmo1512162.patch
   185 Patch19:        mozilla-bmo1512162.patch
   186 Patch20:        mozilla-fix-top-level-asm.patch
   186 Patch20:        mozilla-fix-top-level-asm.patch
   187 Patch21:        mozilla-bmo1504834-part4.patch
   187 Patch21:        mozilla-bmo1504834-part4.patch
   188 Patch22:        mozilla-bmo849632.patch
   188 Patch22:        mozilla-bmo849632.patch
   189 Patch23:        mozilla-bmo1610814.patch
   189 Patch23:        mozilla-bmo1609538.patch
   190 # Firefox/browser
   190 # Firefox/browser
   191 Patch101:       firefox-kde.patch
   191 Patch101:       firefox-kde.patch
   192 Patch102:       firefox-branded-icons.patch
   192 Patch102:       firefox-branded-icons.patch
   193 %endif # only_print_mozconfig
   193 %endif # only_print_mozconfig
   194 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   194 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   325 %patch23 -p1
   325 %patch23 -p1
   326 # Firefox
   326 # Firefox
   327 %patch101 -p1
   327 %patch101 -p1
   328 %patch102 -p1
   328 %patch102 -p1
   329 %endif # only_print_mozconfig
   329 %endif # only_print_mozconfig
   330 # Save config.sub to restore it (for aarch64/ppc64le) later, as it is checked with a checksum
       
   331 cp ./third_party/rust/backtrace-sys/src/libbacktrace/config.sub ./third_party/rust/backtrace-sys/src/libbacktrace/config.sub.save
       
   332 cp ./third_party/rust/backtrace-sys/src/libbacktrace/config.guess ./third_party/rust/backtrace-sys/src/libbacktrace/config.guess.save
       
   333 
   330 
   334 %build
   331 %build
   335 # Restore config.sub file
       
   336 mv ./third_party/rust/backtrace-sys/src/libbacktrace/config.sub.save ./third_party/rust/backtrace-sys/src/libbacktrace/config.sub
       
   337 mv ./third_party/rust/backtrace-sys/src/libbacktrace/config.guess.save ./third_party/rust/backtrace-sys/src/libbacktrace/config.guess
       
   338 %if !%{with only_print_mozconfig}
   332 %if !%{with only_print_mozconfig}
   339 # no need to add build time to binaries
   333 # no need to add build time to binaries
   340 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   334 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   341 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   335 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   342 TIME="\"$(date -d "${modified}" "+%%R")\""
   336 TIME="\"$(date -d "${modified}" "+%%R")\""