MozillaFirefox/firefox-esr.spec
branchfirefox38
changeset 873 b8713c1e2156
parent 865 646495e9e721
child 874 255a6c12c85f
equal deleted inserted replaced
865:646495e9e721 873:b8713c1e2156
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 38
    21 %define major 38
    22 %define mainver %major.1.0
    22 %define mainver %major.1.1
    23 %define update_channel esr38
    23 %define update_channel esr38
    24 %define releasedate 2015062600
    24 %define releasedate 2015080600
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  firefox-esr
    29 %define pkgname  firefox-esr
   130 Source11:       firefox.1
   130 Source11:       firefox.1
   131 Source12:       mozilla-get-app-id
   131 Source12:       mozilla-get-app-id
   132 Source13:       spellcheck.js
   132 Source13:       spellcheck.js
   133 Source14:       create-tar.sh
   133 Source14:       create-tar.sh
   134 Source15:       firefox-appdata.xml
   134 Source15:       firefox-appdata.xml
   135 Source16:       MozillaFirefox.changes
   135 Source16:       firefox-esr.changes
   136 # Gecko/Toolkit
   136 # Gecko/Toolkit
   137 Patch1:         toolkit-download-folder.patch
   137 Patch1:         toolkit-download-folder.patch
   138 Patch2:         mozilla-nongnome-proxies.patch
   138 Patch2:         mozilla-nongnome-proxies.patch
   139 Patch3:         mozilla-prefer_plugin_pref.patch
   139 Patch3:         mozilla-prefer_plugin_pref.patch
   140 Patch4:         mozilla-shared-nss-db.patch
   140 Patch4:         mozilla-shared-nss-db.patch
   272 %patch103 -p1
   272 %patch103 -p1
   273 %patch104 -p1
   273 %patch104 -p1
   274 
   274 
   275 %build
   275 %build
   276 # no need to add build time to binaries
   276 # no need to add build time to binaries
   277 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/MozillaFirefox.changes")"
   277 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{S:16}")"
   278 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   278 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   279 TIME="\"$(date -d "${modified}" "+%%R")\""
   279 TIME="\"$(date -d "${modified}" "+%%R")\""
   280 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   280 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   281 #
   281 #
   282 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   282 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)