MozillaFirefox/MozillaFirefox.spec
branchfirefox46
changeset 909 c6717354928b
parent 908 b29b47737173
child 913 9f3ecc7dc9e3
equal deleted inserted replaced
901:eb9ebe3e2e6a 909:c6717354928b
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 43
    21 %define major 46
    22 %define mainver %major.99
    22 %define mainver %major.0
    23 %define update_channel beta
    23 %define update_channel release
    24 %define releasedate 2016012300
    24 %define releasedate 2016042500
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
    75 BuildRequires:  libidl-devel
    75 BuildRequires:  libidl-devel
    76 BuildRequires:  libiw-devel
    76 BuildRequires:  libiw-devel
    77 BuildRequires:  libnotify-devel
    77 BuildRequires:  libnotify-devel
    78 BuildRequires:  libproxy-devel
    78 BuildRequires:  libproxy-devel
    79 BuildRequires:  makeinfo
    79 BuildRequires:  makeinfo
    80 BuildRequires:  mozilla-nspr-devel >= 4.11
    80 BuildRequires:  mozilla-nspr-devel >= 4.12
    81 BuildRequires:  mozilla-nss-devel >= 3.21
    81 BuildRequires:  mozilla-nss-devel >= 3.22.3
    82 BuildRequires:  nss-shared-helper-devel
    82 BuildRequires:  nss-shared-helper-devel
    83 BuildRequires:  python-devel
    83 BuildRequires:  python-devel
    84 BuildRequires:  startup-notification-devel
    84 BuildRequires:  startup-notification-devel
    85 BuildRequires:  unzip
    85 BuildRequires:  unzip
    86 BuildRequires:  update-desktop-files
    86 BuildRequires:  update-desktop-files
    89 BuildRequires:  zip
    89 BuildRequires:  zip
    90 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    92 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    92 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    93 BuildRequires:  pkgconfig(libpulse)
    93 BuildRequires:  pkgconfig(libpulse)
       
    94 %if 0%{?firefox_use_gtk3}
       
    95 BuildRequires:  pkgconfig(glib-2.0)
       
    96 BuildRequires:  pkgconfig(gobject-2.0)
       
    97 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
       
    98 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
       
    99 %endif
    94 # libavcodec is already used if available for H.264 but
   100 # libavcodec is already used if available for H.264 but
    95 # explicitely loaded by FF. For proper H.264 support the
   101 # explicitely loaded by FF. For proper H.264 support the
    96 # openSUSE delivered version is not sufficient but currently
   102 # openSUSE delivered version is not sufficient but currently
    97 # prevents even the use of the GStreamer method
   103 # prevents even the use of the GStreamer method
    98 # https://bugzilla.mozilla.org/show_bug.cgi?id=1234157
   104 # https://bugzilla.mozilla.org/show_bug.cgi?id=1234157
   146 Source12:       mozilla-get-app-id
   152 Source12:       mozilla-get-app-id
   147 Source13:       spellcheck.js
   153 Source13:       spellcheck.js
   148 Source14:       create-tar.sh
   154 Source14:       create-tar.sh
   149 Source15:       firefox-appdata.xml
   155 Source15:       firefox-appdata.xml
   150 Source16:       MozillaFirefox.changes
   156 Source16:       MozillaFirefox.changes
       
   157 Source17:       l10n_changesets.txt
   151 # Gecko/Toolkit
   158 # Gecko/Toolkit
   152 Patch1:         mozilla-nongnome-proxies.patch
   159 Patch1:         mozilla-nongnome-proxies.patch
   153 Patch2:         mozilla-shared-nss-db.patch
   160 Patch2:         mozilla-shared-nss-db.patch
   154 Patch3:         mozilla-kde.patch
   161 Patch3:         mozilla-kde.patch
   155 Patch4:         mozilla-preferences.patch
   162 Patch4:         mozilla-preferences.patch
   157 Patch6:         mozilla-ntlm-full-path.patch
   164 Patch6:         mozilla-ntlm-full-path.patch
   158 Patch7:         mozilla-repo.patch
   165 Patch7:         mozilla-repo.patch
   159 Patch8:         mozilla-openaes-decl.patch
   166 Patch8:         mozilla-openaes-decl.patch
   160 Patch10:        mozilla-no-stdcxx-check.patch
   167 Patch10:        mozilla-no-stdcxx-check.patch
   161 Patch11:        mozilla-libproxy.patch
   168 Patch11:        mozilla-libproxy.patch
       
   169 Patch12:        mozilla-reduce-files-per-UnifiedBindings.patch
       
   170 Patch13:        mozilla-gtk3_20.patch
       
   171 Patch14:        mozilla-check_return.patch
   162 # Firefox/browser
   172 # Firefox/browser
   163 Patch101:       firefox-kde.patch
   173 Patch101:       firefox-kde.patch
   164 Patch102:       firefox-no-default-ualocale.patch
   174 Patch102:       firefox-no-default-ualocale.patch
   165 Patch103:       firefox-branded-icons.patch
   175 Patch103:       firefox-branded-icons.patch
   166 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   176 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   266 %patch6 -p1
   276 %patch6 -p1
   267 %patch7 -p1
   277 %patch7 -p1
   268 %patch8 -p1
   278 %patch8 -p1
   269 %patch10 -p1
   279 %patch10 -p1
   270 %patch11 -p1
   280 %patch11 -p1
       
   281 %patch12 -p1
       
   282 %if 0%{?firefox_use_gtk3}
       
   283 %patch13 -p1
       
   284 %endif
       
   285 %patch14 -p1
   271 # Firefox
   286 # Firefox
   272 %patch101 -p1
   287 %patch101 -p1
   273 %patch102 -p1
   288 %patch102 -p1
   274 %patch103 -p1
   289 %patch103 -p1
   275 
   290 
   318 ac_add_options --libdir=%{_libdir}
   333 ac_add_options --libdir=%{_libdir}
   319 ac_add_options --sysconfdir=%{_sysconfdir}
   334 ac_add_options --sysconfdir=%{_sysconfdir}
   320 ac_add_options --mandir=%{_mandir}
   335 ac_add_options --mandir=%{_mandir}
   321 ac_add_options --includedir=%{_includedir}
   336 ac_add_options --includedir=%{_includedir}
   322 ac_add_options --enable-release
   337 ac_add_options --enable-release
   323 %if 0%{?suse_version} > 1320
   338 %if 0%{?firefox_use_gtk3}
   324 #ac_add_options --enable-default-toolkit=cairo-gtk3
   339 ac_add_options --enable-default-toolkit=cairo-gtk3
       
   340 %else
       
   341 ac_add_options --enable-default-toolkit=cairo-gtk2
   325 %endif
   342 %endif
   326 %ifarch %ix86 %arm
   343 %ifarch %ix86 %arm
   327 %if 0%{?suse_version} > 1230
   344 %if 0%{?suse_version} > 1230
   328 ac_add_options --disable-optimize
   345 ac_add_options --disable-optimize
   329 %endif
   346 %endif
   354 %endif
   371 %endif
   355 ac_add_options --enable-libproxy
   372 ac_add_options --enable-libproxy
   356 %if ! %crashreporter
   373 %if ! %crashreporter
   357 ac_add_options --disable-crashreporter
   374 ac_add_options --disable-crashreporter
   358 %endif
   375 %endif
   359 # Disable neon for arm as it does not build correctly
       
   360 %ifarch %arm
   376 %ifarch %arm
   361 ac_add_options --disable-neon
   377 ac_add_options --disable-elf-hack
   362 %endif
   378 ac_add_options --with-fpu=vfpv3-d16
   363 %ifnarch %ix86 x86_64
   379 ac_add_options --with-float-abi=hard
       
   380 ac_add_options --with-arch=armv7-a
       
   381 %endif
       
   382 %ifarch %arm aarch64 s390x
   364 ac_add_options --disable-webrtc
   383 ac_add_options --disable-webrtc
   365 %endif
       
   366 # try to use OpenGL-ES on ARM
       
   367 %ifarch %arm aarch64
       
   368 ac_add_options --with-gl-provider=EGL
       
   369 %endif
   384 %endif
   370 EOF
   385 EOF
   371 make -f client.mk build
   386 make -f client.mk build
   372 
   387 
   373 %install
   388 %install
   520 # fdupes
   535 # fdupes
   521 %fdupes %{buildroot}%{progdir}
   536 %fdupes %{buildroot}%{progdir}
   522 %fdupes %{buildroot}%{_datadir}
   537 %fdupes %{buildroot}%{_datadir}
   523 # create breakpad debugsymbols
   538 # create breakpad debugsymbols
   524 %if %crashreporter
   539 %if %crashreporter
   525 SYMBOLS_NAME="firefox-%{version}-%{release}.%{_arch}-%{suse_version}-symbols"
   540 SYMBOLS_NAME="firefox-%{version}-` echo '%{release}' | sed 's@\.[^\.]\+$@@' `.%{_arch}-%{suse_version}-symbols"
   526 make buildsymbols \
   541 make buildsymbols \
   527   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
   542   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
   528   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
   543   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
   529   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
   544   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
   530 if [ -e dist/*symbols.zip ]; then
   545 if [ -e dist/*symbols.zip ]; then
   558 %dir %{progdir}/browser/
   573 %dir %{progdir}/browser/
   559 %dir %{progdir}/browser/chrome/
   574 %dir %{progdir}/browser/chrome/
   560 %dir %{progdir}/browser/extensions/
   575 %dir %{progdir}/browser/extensions/
   561 %{progdir}/browser/components/
   576 %{progdir}/browser/components/
   562 %{progdir}/browser/defaults
   577 %{progdir}/browser/defaults
       
   578 %{progdir}/browser/features/
   563 %{progdir}/browser/icons/
   579 %{progdir}/browser/icons/
   564 %{progdir}/browser/chrome/icons
   580 %{progdir}/browser/chrome/icons
   565 %{progdir}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   581 %{progdir}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
   566 %{progdir}/browser/blocklist.xml
   582 %{progdir}/browser/blocklist.xml
   567 %{progdir}/browser/chrome.manifest
   583 %{progdir}/browser/chrome.manifest
   568 %{progdir}/browser/omni.ja
   584 %{progdir}/browser/omni.ja
   569 %dir %{progdir}/distribution/
   585 %dir %{progdir}/distribution/
   570 %{progdir}/distribution/extensions/
   586 %{progdir}/distribution/extensions/
   571 %{progdir}/components/
       
   572 %{progdir}/defaults/
   587 %{progdir}/defaults/
   573 %{progdir}/dictionaries/
   588 %{progdir}/dictionaries/
   574 %if 0%{?suse_version} > 1320
   589 %if 0%{?firefox_use_gtk3}
   575 #%dir %{progdir}/gtk2
   590 %dir %{progdir}/gtk2
   576 %{progdir}/gtk2/libmozgtk.so
   591 %{progdir}/gtk2/libmozgtk.so
   577 %endif
   592 %endif
   578 %{progdir}/webapprt/
   593 %{progdir}/webapprt/
   579 %{progdir}/gmp-clearkey/
   594 %{progdir}/gmp-clearkey/
   580 %attr(755,root,root) %{progdir}/%{progname}.sh
   595 %attr(755,root,root) %{progdir}/%{progname}.sh
   585 %{progdir}/*.so
   600 %{progdir}/*.so
   586 %{progdir}/omni.ja
   601 %{progdir}/omni.ja
   587 %{progdir}/platform.ini
   602 %{progdir}/platform.ini
   588 %{progdir}/plugin-container
   603 %{progdir}/plugin-container
   589 %{progdir}/webapprt-stub
   604 %{progdir}/webapprt-stub
   590 %{progdir}/chrome.manifest
       
   591 %if %crashreporter
   605 %if %crashreporter
   592 %{progdir}/crashreporter
   606 %{progdir}/crashreporter
   593 %{progdir}/crashreporter.ini
   607 %{progdir}/crashreporter.ini
   594 %{progdir}/Throbber-small.gif
   608 %{progdir}/Throbber-small.gif
   595 %{progdir}/browser/crashreporter-override.ini
   609 %{progdir}/browser/crashreporter-override.ini