MozillaFirefox/MozillaFirefox.spec
branchfirefox24
changeset 668 fc8c1da7ec06
parent 666 0d913ca30238
child 669 4b65b5cfd428
equal deleted inserted replaced
667:6c1407488870 668:fc8c1da7ec06
   298 ac_add_options --disable-tests
   298 ac_add_options --disable-tests
   299 ac_add_options --disable-debug
   299 ac_add_options --disable-debug
   300 ac_add_options --enable-startup-notification
   300 ac_add_options --enable-startup-notification
   301 #ac_add_options --enable-chrome-format=jar
   301 #ac_add_options --enable-chrome-format=jar
   302 ac_add_options --enable-update-channel=%{update_channel}
   302 ac_add_options --enable-update-channel=%{update_channel}
   303 EOF
       
   304 %if %suse_version > 1130
   303 %if %suse_version > 1130
   305 cat << EOF >> $MOZCONFIG
       
   306 ac_add_options --disable-gnomevfs
   304 ac_add_options --disable-gnomevfs
   307 ac_add_options --enable-gio
   305 ac_add_options --enable-gio
   308 EOF
       
   309 %endif
   306 %endif
   310 %if %suse_version < 1220
   307 %if %suse_version < 1220
   311 cat << EOF >> $MOZCONFIG
       
   312 ac_add_options --disable-gstreamer
   308 ac_add_options --disable-gstreamer
   313 EOF
       
   314 %endif
   309 %endif
   315 %if %branding
   310 %if %branding
   316 cat << EOF >> $MOZCONFIG
       
   317 ac_add_options --enable-official-branding
   311 ac_add_options --enable-official-branding
   318 EOF
       
   319 %endif
   312 %endif
   320 %if %suse_version > 1110
   313 %if %suse_version > 1110
   321 cat << EOF >> $MOZCONFIG
       
   322 ac_add_options --enable-libproxy
   314 ac_add_options --enable-libproxy
   323 EOF
       
   324 %endif
   315 %endif
   325 %if ! %crashreporter
   316 %if ! %crashreporter
   326 cat << EOF >> $MOZCONFIG
       
   327 ac_add_options --disable-crashreporter
   317 ac_add_options --disable-crashreporter
   328 EOF
       
   329 %endif
   318 %endif
   330 # Disable neon for arm as it does not build correctly
   319 # Disable neon for arm as it does not build correctly
   331 %ifarch %arm
   320 %ifarch %arm
   332 cat << EOF >> $MOZCONFIG
       
   333 ac_add_options --disable-neon
   321 ac_add_options --disable-neon
       
   322 %endif
       
   323 %ifnarch %ix86 x86_64
       
   324 ac_add_options --disable-webrtc
       
   325 %endif
   334 EOF
   326 EOF
   335 %endif
       
   336 %ifnarch %ix86 x86_64
       
   337 cat << EOF >> $MOZCONFIG
       
   338 ac_add_options --disable-webrtc
       
   339 EOF
       
   340 %endif
       
   341 make -f client.mk build
   327 make -f client.mk build
   342 
   328 
   343 %install
   329 %install
   344 cd $RPM_BUILD_DIR/obj
   330 cd $RPM_BUILD_DIR/obj
   345 source %{SOURCE5}
   331 source %{SOURCE5}