MozillaFirefox/MozillaFirefox.spec
branchfirefox125
changeset 1203 1b3d3cfc69c1
parent 1202 28ebbea625bd
equal deleted inserted replaced
1202:28ebbea625bd 1203:1b3d3cfc69c1
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %%major.99
    30 # mainver %%major.99
    31 %define major          124
    31 %define major          125
    32 %define mainver        %major.0.2
    32 %define mainver        %major.0.3
    33 %define orig_version   124.0.2
    33 %define orig_version   125.0.3
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
    96 BuildRequires:  dbus-1-glib-devel
    96 BuildRequires:  dbus-1-glib-devel
    97 BuildRequires:  dejavu-fonts
    97 BuildRequires:  dejavu-fonts
    98 BuildRequires:  fdupes
    98 BuildRequires:  fdupes
    99 BuildRequires:  memory-constraints
    99 BuildRequires:  memory-constraints
   100 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150600
   100 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150600
   101 BuildRequires:  gcc12
   101 BuildRequires:  gcc13
   102 BuildRequires:  gcc12-c++
   102 BuildRequires:  gcc13-c++
   103 %else
   103 %else
   104 BuildRequires:  gcc-c++
   104 BuildRequires:  gcc-c++
   105 %endif
   105 %endif
   106 BuildRequires:  cargo1.71
   106 BuildRequires:  cargo1.76
   107 BuildRequires:  rust1.71
   107 BuildRequires:  rust1.76
   108 %if 0%{useccache} != 0
   108 %if 0%{useccache} != 0
   109 BuildRequires:  ccache
   109 BuildRequires:  ccache
   110 %endif
   110 %endif
   111 BuildRequires:  libXcomposite-devel
   111 BuildRequires:  libXcomposite-devel
   112 BuildRequires:  libcurl-devel
   112 BuildRequires:  libcurl-devel
   113 BuildRequires:  libiw-devel
   113 BuildRequires:  libiw-devel
   114 BuildRequires:  libproxy-devel
   114 BuildRequires:  libproxy-devel
   115 BuildRequires:  makeinfo
   115 BuildRequires:  makeinfo
   116 BuildRequires:  mozilla-nspr-devel >= 4.35
   116 BuildRequires:  mozilla-nspr-devel >= 4.35
   117 BuildRequires:  mozilla-nss-devel >= 3.98
   117 BuildRequires:  mozilla-nss-devel >= 3.99
   118 BuildRequires:  nasm >= 2.14
   118 BuildRequires:  nasm >= 2.14
   119 BuildRequires:  nodejs >= 12.22.12
   119 BuildRequires:  nodejs >= 12.22.12
   120 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   120 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   121 BuildRequires:  libXtst-devel
   121 BuildRequires:  libXtst-devel
   122 BuildRequires:  python-libxml2
   122 BuildRequires:  python-libxml2
   227 Patch20:        one_swizzle_to_rule_them_all.patch
   227 Patch20:        one_swizzle_to_rule_them_all.patch
   228 Patch21:        svg-rendering.patch
   228 Patch21:        svg-rendering.patch
   229 Patch22:        mozilla-partial-revert-1768632.patch
   229 Patch22:        mozilla-partial-revert-1768632.patch
   230 Patch23:        mozilla-rust-disable-future-incompat.patch
   230 Patch23:        mozilla-rust-disable-future-incompat.patch
   231 Patch24:        mozilla-bmo1822730.patch
   231 Patch24:        mozilla-bmo1822730.patch
       
   232 Patch25:        mozilla-libproxy-fix.patch
   232 # Firefox/browser
   233 # Firefox/browser
   233 Patch101:       firefox-kde.patch
   234 Patch101:       firefox-kde.patch
   234 Patch102:       firefox-branded-icons.patch
   235 Patch102:       firefox-branded-icons.patch
   235 %endif
   236 %endif
   236 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   237 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   379 export BUILD_OFFICIAL=1
   380 export BUILD_OFFICIAL=1
   380 export MOZ_TELEMETRY_REPORTING=1
   381 export MOZ_TELEMETRY_REPORTING=1
   381 export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
   382 export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
   382 export CFLAGS="%{optflags}"
   383 export CFLAGS="%{optflags}"
   383 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150600
   384 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150600
   384 export CC=gcc-12
   385 export CC=gcc-13
   385 export CXX=g++-12
   386 export CXX=g++-13
   386 %else
   387 %else
   387 %if 0%{?clang_build} == 0
   388 %if 0%{?clang_build} == 0
   388 export CC=gcc
   389 export CC=gcc
   389 export CXX=g++
   390 export CXX=g++
   390 %endif
   391 %endif