MozillaFirefox/MozillaFirefox.spec
branchfirefox60
changeset 1047 847ae61baab6
parent 1046 75893a3d8fbe
child 1048 a6a2360bc1bd
--- a/MozillaFirefox/MozillaFirefox.spec	Wed May 02 09:28:53 2018 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Wed May 09 22:06:26 2018 +0200
@@ -18,11 +18,12 @@
 
 
 # changed with every update
-%define major 59
-%define mainver %major.99
-%define update_channel beta
+%define major 60
+%define mainver %major.0
+%define update_channel release
 %define branding 1
-%define releasedate 20180426170554
+%define releasedate 20180503143129
+%define source_prefix firefox-%{mainver}
 
 # PIE, full relro (x86_64 for now)
 %define build_hardened 1
@@ -120,7 +121,7 @@
 License:        MPL-2.0
 Group:          Productivity/Networking/Web/Browsers
 Url:            http://www.mozilla.org/
-Source:         firefox-%{version}-source.tar.xz
+Source:         http://ftp.mozilla.org/pub/firefox/releases/%{version}/source/firefox-%{version}.source.tar.xz
 Source1:        MozillaFirefox.desktop
 Source2:        MozillaFirefox-rpmlintrc
 Source3:        mozilla.sh.in
@@ -141,6 +142,8 @@
 # please get your own set of keys.
 Source18:       mozilla-api-key
 Source19:       google-api-key
+Source20:       http://ftp.mozilla.org/pub/firefox/releases/%{version}/source/firefox-%{version}.source.tar.xz.asc
+Source21:       mozilla.keyring
 # Gecko/Toolkit
 Patch1:         mozilla-nongnome-proxies.patch
 Patch2:         mozilla-kde.patch
@@ -206,7 +209,7 @@
 %package translations-other
 Summary:        Extra translations for %{appname}
 Group:          System/Localization
-Provides:       locale(%{name}:ach;af;an;as;ast;az;bg;bn_BD;bn_IN;br;bs;cak;cy;dsb;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gn;gu_IN;he;hi_IN;hr;hsb;hy_AM;id;is;ka;kab;kk;km;kn;lij;lt;lv;mai;mk;ml;mr;ms;ne-NP;nn_NO;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;te;th;tr;uk;uz;vi;xh)
+Provides:       locale(%{name}:ach;af;an;as;ast;az;bg;bn_BD;bn_IN;br;bs;cak;cy;dsb;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gn;gu_IN;he;hi_IN;hr;hsb;hy_AM;id;is;ka;kab;kk;km;kn;lij;lt;lv;mai;mk;ml;mr;ms;ne-NP;nn_NO;oc;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;te;th;tr;uk;uz;vi;xh)
 Requires:       %{name} = %{version}
 Obsoletes:      %{name}-translations < %{version}-%{release}
 
@@ -248,11 +251,11 @@
 
 %prep
 %if %localize
-%setup -q -n mozilla -b 7 -b 10
+%setup -q -n %{source_prefix} -b 7 -b 10
 %else
-%setup -q -n mozilla
+%setup -q -n %{source_prefix}
 %endif
-cd $RPM_BUILD_DIR/mozilla
+cd $RPM_BUILD_DIR/%{source_prefix}
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
@@ -317,6 +320,9 @@
 export CFLAGS="$CFLAGS -mminimal-toc"
 %endif
 export CXXFLAGS="$CFLAGS"
+%ifarch %{arm}
+export RUSTFLAGS="-Cdebuginfo=0"
+%endif
 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
 cat << EOF > $MOZCONFIG
 mk_add_options MOZILLA_OFFICIAL=1
@@ -371,8 +377,12 @@
 %ifarch %arm
 ac_add_options --with-fpu=vfpv3-d16
 ac_add_options --with-float-abi=hard
+%ifarch armv6l armv6hl
+ac_add_options --with-arch=armv6
+%else
 ac_add_options --with-arch=armv7-a
 %endif
+%endif
 %ifarch %arm s390x
 ac_add_options --disable-webrtc
 %endif
@@ -405,7 +415,7 @@
 %if %localize
 rm -f %{_tmppath}/translations.*
 touch %{_tmppath}/translations.{common,other}
-for locale in $(cat $RPM_BUILD_DIR/mozilla/browser/locales/shipped-locales) ; do
+for locale in $(cat $RPM_BUILD_DIR/%{source_prefix}/browser/locales/shipped-locales) ; do
   case $locale in
    ja-JP-mac|en-US|'')
 	;;
@@ -413,7 +423,7 @@
    	pushd $RPM_BUILD_DIR/compare-locales
 	PYTHONPATH=lib \
 	  scripts/compare-locales -m ../l10n-merged/$locale \
-	  ../mozilla/browser/locales/l10n.ini ../l10n $locale
+	  ../%{source_prefix}/browser/locales/l10n.ini ../l10n $locale
 	popd
 	LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
   	make -C browser/locales langpack-$locale
@@ -444,7 +454,7 @@
      -name "*.xml" -o \
      -name "*.css" | xargs chmod a-x
 # remove mkdir.done files from installed base
-find %{buildroot}%{progdir} -name ".mkdir.done" | xargs rm
+find %{buildroot}%{progdir} -name ".mkdir.done" | xargs rm || :
 # overwrite the mozilla start-script and link it to /usr/bin
 mkdir --parents %{buildroot}/usr/bin
 sed "s:%%PREFIX:%{_prefix}:g