MozillaFirefox/MozillaFirefox.spec
branchfirefox104
changeset 1178 e27c6e9c5c63
parent 1177 4bb6d80fcc64
child 1179 c19c9e7820ef
equal deleted inserted replaced
1177:4bb6d80fcc64 1178:e27c6e9c5c63
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %major.99
    30 # mainver %major.99
    31 %define major          103
    31 %define major          104
    32 %define mainver        %major.0.2
    32 %define mainver        %major.0.2
    33 %define orig_version   103.0.2
    33 %define orig_version   104.0.2
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
   104 # a different method for provides that we can use to request a
   104 # a different method for provides that we can use to request a
   105 # specific version
   105 # specific version
   106 # minimal requirement:
   106 # minimal requirement:
   107 BuildRequires:  rust+cargo >= 1.59
   107 BuildRequires:  rust+cargo >= 1.59
   108 # actually used upstream:
   108 # actually used upstream:
   109 BuildRequires:  cargo1.61
   109 BuildRequires:  cargo1.62
   110 BuildRequires:  rust1.61
   110 BuildRequires:  rust1.62
   111 %endif
   111 %endif
   112 %if 0%{useccache} != 0
   112 %if 0%{useccache} != 0
   113 BuildRequires:  ccache
   113 BuildRequires:  ccache
   114 %endif
   114 %endif
   115 BuildRequires:  libXcomposite-devel
   115 BuildRequires:  libXcomposite-devel
   116 BuildRequires:  libcurl-devel
   116 BuildRequires:  libcurl-devel
   117 BuildRequires:  libiw-devel
   117 BuildRequires:  libiw-devel
   118 BuildRequires:  libproxy-devel
   118 BuildRequires:  libproxy-devel
   119 BuildRequires:  makeinfo
   119 BuildRequires:  makeinfo
   120 BuildRequires:  mozilla-nspr-devel >= 4.34
   120 BuildRequires:  mozilla-nspr-devel >= 4.34.1
   121 BuildRequires:  mozilla-nss-devel >= 3.80
   121 BuildRequires:  mozilla-nss-devel >= 3.81
   122 BuildRequires:  nasm >= 2.14
   122 BuildRequires:  nasm >= 2.14
   123 BuildRequires:  nodejs >= 10.22.1
   123 BuildRequires:  nodejs >= 10.22.1
   124 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   124 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   125 BuildRequires:  python-libxml2
   125 BuildRequires:  python-libxml2
   126 BuildRequires:  python36
   126 BuildRequires:  python36
   399 EOF
   399 EOF
   400 # Done with env-variables.
   400 # Done with env-variables.
   401 source ./.obsenv.sh
   401 source ./.obsenv.sh
   402 
   402 
   403 %ifarch aarch64 %arm ppc64 ppc64le
   403 %ifarch aarch64 %arm ppc64 ppc64le
   404 %limit_build -m 2000
   404 %limit_build -m 2500
   405 %endif
   405 %endif
   406 
   406 
   407 # Generating mozconfig
   407 # Generating mozconfig
   408 cat << EOF > $MOZCONFIG
   408 cat << EOF > $MOZCONFIG
   409 mk_add_options MOZILLA_OFFICIAL=1
   409 mk_add_options MOZILLA_OFFICIAL=1