MozillaFirefox/MozillaFirefox.spec
changeset 934 b61e849fe451
parent 933 7f60766aae16
child 935 9ae2b79d3bb1
--- a/MozillaFirefox/MozillaFirefox.spec	Mon Aug 01 14:45:11 2016 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Wed Jan 18 22:06:23 2017 +0100
@@ -18,10 +18,10 @@
 
 
 # changed with every update
-%define major 48
-%define mainver %major.0
+%define major 50
+%define mainver %major.1.0
 %define update_channel release
-%define releasedate 20160730000000
+%define releasedate 20161212000000
 
 # PIE, full relro (x86_64 for now)
 %define build_hardened 1
@@ -54,10 +54,10 @@
 %define branding 1
 %endif
 %define localize 1
-%ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
+%ifarch %ix86 x86_64
+%define crashreporter 1
+%else
 %define crashreporter 0
-%else
-%define crashreporter 1
 %endif
 
 Name:           %{pkgname}
@@ -75,7 +75,7 @@
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
 BuildRequires:  mozilla-nspr-devel >= 4.12
-BuildRequires:  mozilla-nss-devel >= 3.24
+BuildRequires:  mozilla-nss-devel >= 3.26.2
 BuildRequires:  nss-shared-helper-devel
 BuildRequires:  python-devel
 BuildRequires:  startup-notification-devel
@@ -144,15 +144,17 @@
 Patch8:         mozilla-openaes-decl.patch
 Patch10:        mozilla-no-stdcxx-check.patch
 Patch11:        mozilla-reduce-files-per-UnifiedBindings.patch
-Patch12:        mozilla-gtk3_20.patch
 Patch13:        mozilla-check_return.patch
-Patch15:        mozilla-exclude-nametablecpp.patch
-Patch16:        mozilla-aarch64-48bit-va.patch
+Patch14:        mozilla-skia-overflow.patch
 Patch17:        mozilla-binutils-visibility.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-no-default-ualocale.patch
 Patch103:       firefox-branded-icons.patch
+# hotfix
+Patch150:       mozilla-flex_buffer_overrun.patch
+Patch200:       mozilla-aarch64-startup-crash.patch
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 Requires(post):   coreutils shared-mime-info desktop-file-utils
 Requires(postun): shared-mime-info desktop-file-utils
@@ -201,7 +203,7 @@
 %package translations-other
 Summary:        Extra translations for %{appname}
 Group:          System/Localization
-Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;uz;vi;zu)
+Provides:       locale(%{name}:ach;af;an;as;ast;az;be;bg;bn_BD;bn_IN;br;bs;cak;cy;dsb;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gn;gu_IN;he;hi_IN;hr;hsb;hy_AM;id;is;kk;km;kn;lij;lt;lv;mai;mk;ml;mr;ms;nn_NO;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;te;th;tr;uk;uz;vi;xh)
 Requires:       %{name} = %{version}
 Obsoletes:      %{name}-translations < %{version}-%{release}
 
@@ -257,17 +259,15 @@
 %patch8 -p1
 %patch10 -p1
 %patch11 -p1
-%if 0%{?firefox_use_gtk3}
-%patch12 -p1
-%endif
 %patch13 -p1
-%patch15 -p1
-%patch16 -p1
+%patch14 -p1
 %patch17 -p1
 # Firefox
 %patch101 -p1
 %patch102 -p1
 %patch103 -p1
+%patch150 -p1
+%patch200 -p1
 
 %build
 # no need to add build time to binaries
@@ -320,6 +320,8 @@
 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
 . \$topsrcdir/browser/config/mozconfig
 ac_add_options --prefix=%{_prefix}
+ac_add_options --libdir=%{_libdir}
+ac_add_options --includedir=%{_includedir}
 ac_add_options --enable-release
 %if 0%{?firefox_use_gtk3}
 ac_add_options --enable-default-toolkit=cairo-gtk3
@@ -334,7 +336,7 @@
 ac_add_options --disable-optimize
 %endif
 %endif
-%ifarch ppc ppc64 ppc64le aarch64 %arm
+%ifarch ppc ppc64 ppc64le %arm
 ac_add_options --disable-elf-hack
 %endif
 ac_add_options --with-system-nspr
@@ -363,7 +365,7 @@
 ac_add_options --with-float-abi=hard
 ac_add_options --with-arch=armv7-a
 %endif
-%ifarch %arm aarch64 s390x
+%ifarch %arm s390x
 ac_add_options --disable-webrtc
 %endif
 EOF
@@ -583,6 +585,7 @@
 %{progdir}/*.so
 %{progdir}/icudt56l.dat
 %{progdir}/omni.ja
+%{progdir}/fonts/
 %{progdir}/platform.ini
 %{progdir}/plugin-container
 %if %crashreporter