MozillaFirefox/MozillaFirefox.spec
changeset 934 b61e849fe451
parent 933 7f60766aae16
child 935 9ae2b79d3bb1
equal deleted inserted replaced
923:3cc9f17ca9bb 934:b61e849fe451
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 48
    21 %define major 50
    22 %define mainver %major.0
    22 %define mainver %major.1.0
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 20160730000000
    24 %define releasedate 20161212000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 # general build definitions
    29 # general build definitions
    52 %define branding 0
    52 %define branding 0
    53 %else
    53 %else
    54 %define branding 1
    54 %define branding 1
    55 %endif
    55 %endif
    56 %define localize 1
    56 %define localize 1
    57 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
    57 %ifarch %ix86 x86_64
       
    58 %define crashreporter 1
       
    59 %else
    58 %define crashreporter 0
    60 %define crashreporter 0
    59 %else
       
    60 %define crashreporter 1
       
    61 %endif
    61 %endif
    62 
    62 
    63 Name:           %{pkgname}
    63 Name:           %{pkgname}
    64 BuildRequires:  Mesa-devel
    64 BuildRequires:  Mesa-devel
    65 BuildRequires:  autoconf213
    65 BuildRequires:  autoconf213
    73 BuildRequires:  libiw-devel
    73 BuildRequires:  libiw-devel
    74 BuildRequires:  libnotify-devel
    74 BuildRequires:  libnotify-devel
    75 BuildRequires:  libproxy-devel
    75 BuildRequires:  libproxy-devel
    76 BuildRequires:  makeinfo
    76 BuildRequires:  makeinfo
    77 BuildRequires:  mozilla-nspr-devel >= 4.12
    77 BuildRequires:  mozilla-nspr-devel >= 4.12
    78 BuildRequires:  mozilla-nss-devel >= 3.24
    78 BuildRequires:  mozilla-nss-devel >= 3.26.2
    79 BuildRequires:  nss-shared-helper-devel
    79 BuildRequires:  nss-shared-helper-devel
    80 BuildRequires:  python-devel
    80 BuildRequires:  python-devel
    81 BuildRequires:  startup-notification-devel
    81 BuildRequires:  startup-notification-devel
    82 BuildRequires:  unzip
    82 BuildRequires:  unzip
    83 BuildRequires:  update-desktop-files
    83 BuildRequires:  update-desktop-files
   142 Patch5:         mozilla-language.patch
   142 Patch5:         mozilla-language.patch
   143 Patch6:         mozilla-ntlm-full-path.patch
   143 Patch6:         mozilla-ntlm-full-path.patch
   144 Patch8:         mozilla-openaes-decl.patch
   144 Patch8:         mozilla-openaes-decl.patch
   145 Patch10:        mozilla-no-stdcxx-check.patch
   145 Patch10:        mozilla-no-stdcxx-check.patch
   146 Patch11:        mozilla-reduce-files-per-UnifiedBindings.patch
   146 Patch11:        mozilla-reduce-files-per-UnifiedBindings.patch
   147 Patch12:        mozilla-gtk3_20.patch
       
   148 Patch13:        mozilla-check_return.patch
   147 Patch13:        mozilla-check_return.patch
   149 Patch15:        mozilla-exclude-nametablecpp.patch
   148 Patch14:        mozilla-skia-overflow.patch
   150 Patch16:        mozilla-aarch64-48bit-va.patch
       
   151 Patch17:        mozilla-binutils-visibility.patch
   149 Patch17:        mozilla-binutils-visibility.patch
   152 # Firefox/browser
   150 # Firefox/browser
   153 Patch101:       firefox-kde.patch
   151 Patch101:       firefox-kde.patch
   154 Patch102:       firefox-no-default-ualocale.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   155 Patch103:       firefox-branded-icons.patch
   153 Patch103:       firefox-branded-icons.patch
       
   154 # hotfix
       
   155 Patch150:       mozilla-flex_buffer_overrun.patch
       
   156 Patch200:       mozilla-aarch64-startup-crash.patch
       
   157 
   156 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   158 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   157 Requires(post):   coreutils shared-mime-info desktop-file-utils
   159 Requires(post):   coreutils shared-mime-info desktop-file-utils
   158 Requires(postun): shared-mime-info desktop-file-utils
   160 Requires(postun): shared-mime-info desktop-file-utils
   159 %if %branding
   161 %if %branding
   160 Requires:       %{name}-branding > 39.0
   162 Requires:       %{name}-branding > 39.0
   199 of %{appname}.
   201 of %{appname}.
   200 
   202 
   201 %package translations-other
   203 %package translations-other
   202 Summary:        Extra translations for %{appname}
   204 Summary:        Extra translations for %{appname}
   203 Group:          System/Localization
   205 Group:          System/Localization
   204 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;uz;vi;zu)
   206 Provides:       locale(%{name}:ach;af;an;as;ast;az;be;bg;bn_BD;bn_IN;br;bs;cak;cy;dsb;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gn;gu_IN;he;hi_IN;hr;hsb;hy_AM;id;is;kk;km;kn;lij;lt;lv;mai;mk;ml;mr;ms;nn_NO;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;te;th;tr;uk;uz;vi;xh)
   205 Requires:       %{name} = %{version}
   207 Requires:       %{name} = %{version}
   206 Obsoletes:      %{name}-translations < %{version}-%{release}
   208 Obsoletes:      %{name}-translations < %{version}-%{release}
   207 
   209 
   208 %description translations-other
   210 %description translations-other
   209 This package contains rarely used languages for the user interface
   211 This package contains rarely used languages for the user interface
   255 %patch5 -p1
   257 %patch5 -p1
   256 %patch6 -p1
   258 %patch6 -p1
   257 %patch8 -p1
   259 %patch8 -p1
   258 %patch10 -p1
   260 %patch10 -p1
   259 %patch11 -p1
   261 %patch11 -p1
   260 %if 0%{?firefox_use_gtk3}
       
   261 %patch12 -p1
       
   262 %endif
       
   263 %patch13 -p1
   262 %patch13 -p1
   264 %patch15 -p1
   263 %patch14 -p1
   265 %patch16 -p1
       
   266 %patch17 -p1
   264 %patch17 -p1
   267 # Firefox
   265 # Firefox
   268 %patch101 -p1
   266 %patch101 -p1
   269 %patch102 -p1
   267 %patch102 -p1
   270 %patch103 -p1
   268 %patch103 -p1
       
   269 %patch150 -p1
       
   270 %patch200 -p1
   271 
   271 
   272 %build
   272 %build
   273 # no need to add build time to binaries
   273 # no need to add build time to binaries
   274 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/MozillaFirefox.changes")"
   274 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/MozillaFirefox.changes")"
   275 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   275 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   318 mk_add_options BUILD_OFFICIAL=1
   318 mk_add_options BUILD_OFFICIAL=1
   319 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   319 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   320 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   320 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   321 . \$topsrcdir/browser/config/mozconfig
   321 . \$topsrcdir/browser/config/mozconfig
   322 ac_add_options --prefix=%{_prefix}
   322 ac_add_options --prefix=%{_prefix}
       
   323 ac_add_options --libdir=%{_libdir}
       
   324 ac_add_options --includedir=%{_includedir}
   323 ac_add_options --enable-release
   325 ac_add_options --enable-release
   324 %if 0%{?firefox_use_gtk3}
   326 %if 0%{?firefox_use_gtk3}
   325 ac_add_options --enable-default-toolkit=cairo-gtk3
   327 ac_add_options --enable-default-toolkit=cairo-gtk3
   326 %else
   328 %else
   327 ac_add_options --enable-default-toolkit=cairo-gtk2
   329 ac_add_options --enable-default-toolkit=cairo-gtk2
   332 %ifarch %ix86 %arm
   334 %ifarch %ix86 %arm
   333 %if 0%{?suse_version} > 1230
   335 %if 0%{?suse_version} > 1230
   334 ac_add_options --disable-optimize
   336 ac_add_options --disable-optimize
   335 %endif
   337 %endif
   336 %endif
   338 %endif
   337 %ifarch ppc ppc64 ppc64le aarch64 %arm
   339 %ifarch ppc ppc64 ppc64le %arm
   338 ac_add_options --disable-elf-hack
   340 ac_add_options --disable-elf-hack
   339 %endif
   341 %endif
   340 ac_add_options --with-system-nspr
   342 ac_add_options --with-system-nspr
   341 ac_add_options --with-system-nss
   343 ac_add_options --with-system-nss
   342 %if %{localize}
   344 %if %{localize}
   361 %ifarch %arm
   363 %ifarch %arm
   362 ac_add_options --with-fpu=vfpv3-d16
   364 ac_add_options --with-fpu=vfpv3-d16
   363 ac_add_options --with-float-abi=hard
   365 ac_add_options --with-float-abi=hard
   364 ac_add_options --with-arch=armv7-a
   366 ac_add_options --with-arch=armv7-a
   365 %endif
   367 %endif
   366 %ifarch %arm aarch64 s390x
   368 %ifarch %arm s390x
   367 ac_add_options --disable-webrtc
   369 ac_add_options --disable-webrtc
   368 %endif
   370 %endif
   369 EOF
   371 EOF
   370 make -f client.mk build
   372 make -f client.mk build
   371 
   373 
   581 %{progdir}/application.ini
   583 %{progdir}/application.ini
   582 %{progdir}/dependentlibs.list
   584 %{progdir}/dependentlibs.list
   583 %{progdir}/*.so
   585 %{progdir}/*.so
   584 %{progdir}/icudt56l.dat
   586 %{progdir}/icudt56l.dat
   585 %{progdir}/omni.ja
   587 %{progdir}/omni.ja
       
   588 %{progdir}/fonts/
   586 %{progdir}/platform.ini
   589 %{progdir}/platform.ini
   587 %{progdir}/plugin-container
   590 %{progdir}/plugin-container
   588 %if %crashreporter
   591 %if %crashreporter
   589 %{progdir}/crashreporter
   592 %{progdir}/crashreporter
   590 %{progdir}/crashreporter.ini
   593 %{progdir}/crashreporter.ini