MozillaFirefox/MozillaFirefox.spec
changeset 922 bf541a540a74
parent 921 4f801233e935
child 923 3cc9f17ca9bb
--- a/MozillaFirefox/MozillaFirefox.spec	Wed Jun 08 13:45:00 2016 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Sat Jul 30 10:49:37 2016 +0200
@@ -19,9 +19,9 @@
 
 # changed with every update
 %define major 47
-%define mainver %major.0
+%define mainver %major.0.1
 %define update_channel release
-%define releasedate 20160606000000
+%define releasedate 20160628000000
 
 # PIE, full relro (x86_64 for now)
 %define build_hardened 1
@@ -95,7 +95,7 @@
 # openSUSE version is currently not able to play H.264
 # therefore the Packman version is required
 # minimum version of libavcodec is 53
-#Recommends:     libavcodec
+Recommends:     libavcodec-full >= 0.10.16
 Version:        %{mainver}
 Release:        0
 %if "%{name}" == "MozillaFirefox"
@@ -148,6 +148,8 @@
 Patch13:        mozilla-check_return.patch
 Patch14:        mozilla-gcc6.patch
 Patch15:        mozilla-exclude-nametablecpp.patch
+Patch16:        mozilla-aarch64-48bit-va.patch
+Patch17:        mozilla-binutils-visibility.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-no-default-ualocale.patch
@@ -262,6 +264,8 @@
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
+%patch17 -p1
 # Firefox
 %patch101 -p1
 %patch102 -p1
@@ -290,6 +294,10 @@
 export MOZ_TELEMETRY_REPORTING=1
 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
 export CFLAGS="%{optflags} -fno-strict-aliasing"
+# boo#986541: add -fno-delete-null-pointer-checks and -fno-inline-small-functions for gcc6
+%if 0%{?suse_version} > 1320
+export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-inline-small-functions"
+%endif
 %ifarch %arm
 export CFLAGS="${CFLAGS/-g / }"
 %endif