MozillaFirefox/MozillaFirefox.spec
changeset 922 bf541a540a74
parent 921 4f801233e935
child 923 3cc9f17ca9bb
equal deleted inserted replaced
916:2f9f2e040647 922:bf541a540a74
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 47
    21 %define major 47
    22 %define mainver %major.0
    22 %define mainver %major.0.1
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 20160606000000
    24 %define releasedate 20160628000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 # general build definitions
    29 # general build definitions
    93 %endif
    93 %endif
    94 # libavcodec is required for H.264 support but the
    94 # libavcodec is required for H.264 support but the
    95 # openSUSE version is currently not able to play H.264
    95 # openSUSE version is currently not able to play H.264
    96 # therefore the Packman version is required
    96 # therefore the Packman version is required
    97 # minimum version of libavcodec is 53
    97 # minimum version of libavcodec is 53
    98 #Recommends:     libavcodec
    98 Recommends:     libavcodec-full >= 0.10.16
    99 Version:        %{mainver}
    99 Version:        %{mainver}
   100 Release:        0
   100 Release:        0
   101 %if "%{name}" == "MozillaFirefox"
   101 %if "%{name}" == "MozillaFirefox"
   102 Provides:       firefox = %{mainver}
   102 Provides:       firefox = %{mainver}
   103 Provides:       firefox = %{version}-%{release}
   103 Provides:       firefox = %{version}-%{release}
   146 Patch11:        mozilla-reduce-files-per-UnifiedBindings.patch
   146 Patch11:        mozilla-reduce-files-per-UnifiedBindings.patch
   147 Patch12:        mozilla-gtk3_20.patch
   147 Patch12:        mozilla-gtk3_20.patch
   148 Patch13:        mozilla-check_return.patch
   148 Patch13:        mozilla-check_return.patch
   149 Patch14:        mozilla-gcc6.patch
   149 Patch14:        mozilla-gcc6.patch
   150 Patch15:        mozilla-exclude-nametablecpp.patch
   150 Patch15:        mozilla-exclude-nametablecpp.patch
       
   151 Patch16:        mozilla-aarch64-48bit-va.patch
       
   152 Patch17:        mozilla-binutils-visibility.patch
   151 # Firefox/browser
   153 # Firefox/browser
   152 Patch101:       firefox-kde.patch
   154 Patch101:       firefox-kde.patch
   153 Patch102:       firefox-no-default-ualocale.patch
   155 Patch102:       firefox-no-default-ualocale.patch
   154 Patch103:       firefox-branded-icons.patch
   156 Patch103:       firefox-branded-icons.patch
   155 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   157 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   260 %patch12 -p1
   262 %patch12 -p1
   261 %endif
   263 %endif
   262 %patch13 -p1
   264 %patch13 -p1
   263 %patch14 -p1
   265 %patch14 -p1
   264 %patch15 -p1
   266 %patch15 -p1
       
   267 %patch16 -p1
       
   268 %patch17 -p1
   265 # Firefox
   269 # Firefox
   266 %patch101 -p1
   270 %patch101 -p1
   267 %patch102 -p1
   271 %patch102 -p1
   268 %patch103 -p1
   272 %patch103 -p1
   269 
   273 
   288 export MOZILLA_OFFICIAL=1
   292 export MOZILLA_OFFICIAL=1
   289 export BUILD_OFFICIAL=1
   293 export BUILD_OFFICIAL=1
   290 export MOZ_TELEMETRY_REPORTING=1
   294 export MOZ_TELEMETRY_REPORTING=1
   291 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
   295 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
   292 export CFLAGS="%{optflags} -fno-strict-aliasing"
   296 export CFLAGS="%{optflags} -fno-strict-aliasing"
       
   297 # boo#986541: add -fno-delete-null-pointer-checks and -fno-inline-small-functions for gcc6
       
   298 %if 0%{?suse_version} > 1320
       
   299 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-inline-small-functions"
       
   300 %endif
   293 %ifarch %arm
   301 %ifarch %arm
   294 export CFLAGS="${CFLAGS/-g / }"
   302 export CFLAGS="${CFLAGS/-g / }"
   295 %endif
   303 %endif
   296 %ifarch %arm %ix86
   304 %ifarch %arm %ix86
   297 # Limit RAM usage during link
   305 # Limit RAM usage during link